Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:

THEMA: errors on backend and frontend

errors on backend and frontend 6 Jahre 4 Monate her #2986

  • ernst67
  • ernst67s Avatar
  • OFFLINE
  • Fresh Boarder
  • Beiträge: 5
  • Karma: 0
Hello,

After installation, when i navigate to the component settings in backend, I get the followinr errors:
( ! ) Notice: Undefined property: JAdministrator::$JComponentTitle in C:\wamp\www\jem\administrator\modules\mod_title\mod_title.php on line 13
Call Stack
#	Time	Memory	Function	Location
1	0.0004	386920	{main}( )	..\index.php:0
2	0.1863	8829264	JAdministrator->render( )	..\index.php:52
3	0.1919	8970400	JDocumentHTML->render( )	..\application.php:202
4	0.1919	8970400	JDocumentHTML->_renderTemplate( )	..\html.php:433
5	0.2129	9282168	JDocumentHTML->getBuffer( )	..\html.php:655
6	0.2129	9282544	JDocumentRendererModules->render( )	..\html.php:371
7	0.2130	9283136	JDocumentRendererModule->render( )	..\modules.php:39
8	0.2132	9283584	JModuleHelper::renderModule( )	..\module.php:107
9	0.2161	9330872	include( 'C:\wamp\www\jem\administrator\modules\mod_title\mod_title.php' )	..\helper.php:175

So I can not reach the administration part of the componentt and set the image url.

Then, in frontend, I get this (after selecting image and clicking "insert":
( ! ) Notice: Uninitialized string offset: 1 in C:\wamp\www\jem\libraries\joomla\filesystem\path.php on line 210
Call Stack
#	Time	Memory	Function	Location
1	0.0005	387648	{main}( )	..\index.php:0
2	0.1770	7929536	JSite->dispatch( )	..\index.php:42
3	0.1833	7983056	JComponentHelper::renderComponent( )	..\application.php:197
4	0.1951	8013256	JComponentHelper::executeComponent( )	..\helper.php:351
5	0.1958	8059488	require_once( 'C:\wamp\www\jem\components\com_simpleimageupload\simpleimageupload.php' )	..\helper.php:383
6	0.2021	8426816	JController->execute( )	..\simpleimageupload.php:20
7	0.2022	8426864	SimpleImageUploadControllerUpload->upload( )	..\controller.php:761

but i think that is a result of not setting image directory?

errors on backend and frontend 6 Jahre 4 Monate her #2989

  • Jonny132
  • Jonny132s Avatar
  • OFFLINE
  • Administrator
  • Beiträge: 151
  • Dank erhalten: 3
  • Karma: 4
Hello ernst67,

which Joomla-Version are you using?
I'm a little confused, because the Extension is a Plugin in first Place and not a Component.

errors on backend and frontend 6 Jahre 4 Monate her #2990

  • ernst67
  • ernst67s Avatar
  • OFFLINE
  • Fresh Boarder
  • Beiträge: 5
  • Karma: 0
Hello Jonny,

I was using Joomla 2.5.9. The component screen gave an error.

I noy updated to 2.5.14 and the error is gone....

I thought the basic image path for the plugin had to be set in the component. But there is no setting option there. Neuter there is a setting in the plugin itself...

Now I get this get this when I inset an image...:


( ! ) Notice: Uninitialized string offset: 1 in C:\wamp\www\jem\libraries\joomla\filesystem\path.php on line 215
Call Stack
# Time Memory Function Location
1 0.0006 385088 {main}( ) ..\index.php:0
2 0.1748 7917384 JSite->dispatch( ) ..\index.php:42
3 0.1814 7970912 JComponentHelper::renderComponent( ) ..\application.php:197
4 0.1928 8001096 JComponentHelper::executeComponent( ) ..\helper.php:351
5 0.1934 8047336 require_once( 'C:\wamp\www\jem\components\com_simpleimageupload\simpleimageupload.php' ) ..\helper.php:383
6 0.2305 8414672 JController->execute( ) ..\simpleimageupload.php:20
7 0.2305 8414720 SimpleImageUploadControllerUpload->upload( ) ..\controller.php:761
8 0.2567 9136456 JFile::upload( ) ..\upload.php:111
9 0.2568 9136736 JFolder::create( ) ..\file.php:450
10 0.2580 9189552 JFolder::create( ) ..\folder.php:188
11 0.2581 9189696 JFolder::create( ) ..\folder.php:188
12 0.2582 9189824 JFolder::create( ) ..\folder.php:188
13 0.2583 9189944 JFolder::create( ) ..\folder.php:188
14 0.2583 9190040 JFolder::exists( ) ..\folder.php:176
15 0.2583 9190040 JPath::clean( ) ..\folder.php:458

And I suspect it has something to do with an incorrect path setting.

But where to set..??

I'm using JCE as editor.

Thanks for your help!

errors on backend and frontend 6 Jahre 4 Monate her #2994

  • Jonny132
  • Jonny132s Avatar
  • OFFLINE
  • Administrator
  • Beiträge: 151
  • Dank erhalten: 3
  • Karma: 4
Hi,

the settings are indeed in the component. You may have not seen the 'Options' button on the right top corner.

Could it be, that you have no rights to Change/Add directories?

errors on backend and frontend 6 Jahre 4 Monate her #3015

  • ernst67
  • ernst67s Avatar
  • OFFLINE
  • Fresh Boarder
  • Beiträge: 5
  • Karma: 0
Hi Jonny,

Thanks for you reply.

Oops, I did miss the options setting. But the default was already set to 'images', and that folder exists indeed.

I just tested when logged in as administrator, and still got the same error.

Then I tried the same thing from the back end, and this is what I got:

simpleimageupload.jpg


Maybe that gives a better clue? Seems like I can't create a folder, but the path is really strange....:
\c:

errors on backend and frontend 6 Jahre 4 Monate her #3019

  • Jonny132
  • Jonny132s Avatar
  • OFFLINE
  • Administrator
  • Beiträge: 151
  • Dank erhalten: 3
  • Karma: 4
Hi,

i see you're in a local installation.

Please try to make this change:
Go to the componentspath --> "com_simpleimageupload/admin/controllers/upload.php"

Search the line
$folder = DS.JPATH_ROOT.DS.$folder;
and change it to
$folder = JPATH_ROOT.DS.$folder;

Also you have to change it in the Site-view in --> "com_simpleimageupload/site/controllers/upload.php"

Maybe now it works... The leading slash should now be gone.

errors on backend and frontend 6 Jahre 4 Monate her #3021

  • ernst67
  • ernst67s Avatar
  • OFFLINE
  • Fresh Boarder
  • Beiträge: 5
  • Karma: 0
OK, this works better :-)

... but the system does not "upload" any image to my local machine. So tomorrow I will test it on the live website, but have to make a backup first.

I will let you know how it went. Thank you so far for your help!

:-)
Letzte Änderung: 6 Jahre 4 Monate her von ernst67.

errors on backend and frontend 6 Jahre 4 Monate her #3026

  • Jonny132
  • Jonny132s Avatar
  • OFFLINE
  • Administrator
  • Beiträge: 151
  • Dank erhalten: 3
  • Karma: 4
Well, I'm glad it 'works' at least a little ;)

Ok, I'm looking forwar to your response.
By the way -> the upload mechanism is the standard joomla upload-function in the standard image upload plugin.
So it should work if the standard upload works too.

errors on backend and frontend 6 Jahre 4 Monate her #3027

  • ernst67
  • ernst67s Avatar
  • OFFLINE
  • Fresh Boarder
  • Beiträge: 5
  • Karma: 0
Hallo Jonny,

It works! :-)
Thanks very much for your assistance.

Keep up the good work!

Ernst

errors on backend and frontend 6 Jahre 4 Monate her #3030

  • Jonny132
  • Jonny132s Avatar
  • OFFLINE
  • Administrator
  • Beiträge: 151
  • Dank erhalten: 3
  • Karma: 4
Good news,

Thanks!
Ladezeit der Seite: 0.355 Sekunden